< 返回技术文档列表

php5.2.17无法在cPanel中安装如何解决

发布时间:2020-12-19 08:01:11

本篇文章给大家分享的是有关php5.2.17无法在cPanel中安装如何解决,小编觉得挺实用的,因此分享给大家学习,希望大家阅读完这篇文章后可以有所收获,话不多说,跟着小编一起来看看吧。

1. 准备cpanel专供php

# cd /var/cpanel/easy/apache/custom_opt_mods
# wget http://docs.cpanel.net/twiki/pub/EasyApache/EasyApacheCustomModules/custom_opt_mod-PHP5217.tar.gz
# tar -xzvf custom_opt_mod-PHP5217.tar.gz

2. 通过easyApache重装

搜索easyApache,然后一步步看图。

php5.2.17无法在cPanel中安装如何解决

easyApache

php5.2.17无法在cPanel中安装如何解决

cPanel安装php5.2.17

php5.2.17无法在cPanel中安装如何解决

cPanel安装php5.2.17

php5.2.17无法在cPanel中安装如何解决

cPanel安装php5.2.17

php5.2.17无法在cPanel中安装如何解决

cPanel安装php5.2.17

然后和往常一样一步步往下走即可完成。

3. php扩展配置

因为这不是cPanel原生的安装,所以没有php的扩展选项,它会根据php压缩包内的默认配置参数安装。如果你需要支持额外选项,例如gd和ftp,如下操作:

# cat /var/cpanel/easy/apache/rawopts/PHP-5.2.17
--with-gd
--enable-ftp
一行一个,它会解析成–with-gd –enable-ftp,然后整合到configure后面。

以上就是php5.2.17无法在cPanel中安装如何解决,小编相信有部分知识点可能是我们日常工作会见到或用到的。希望你能通过这篇文章学到更多知识。更多详情敬请关注血鸟云行业资讯频道。


/template/Home/Zkeys/PC/Static